RIP・RIPng

1. プロトコル概要

RIP(Routing Information Protocol)は、ディスタンスベクタ型ルーティングプロトコルであり、TCP/IPネットワーク向けに設計されたIGP(インテリアゲートウェイ)の1つです。
メトリックとして宛先までに通過しなければならないネットワーク数(ホップ数)が使用されるため、遅延・負荷・信頼性などのリアルタイムな情報を考慮しなければいけないネットワークには向きませんが、設定が用意であり負荷も少ないために比較的小さなネットワーク内での使用に適しています。
本製品では、以下のRIPバージョンに対応しています。

  • RIPv1(RFC1058)
    OSPF(Open Shortest Path First)に比べて計算負荷が非常に少ないため、計算機の能力が不足していた頃に広く普及しました。
    以下のような特徴があります。

    • 計算負荷が非常に少ない。

    • ホップ数が15以上となる大きなネットワークでは使用できない。

    • ネットワーク全体の経路が完全に収束するまでの時間が長い。

    • 障害を検知するまでの時間が長い。

    • リンクダウンが発生するとCount-to-Infinity問題が起きる可能性がある。

  • RIPv2(RFC2453)
    RIPv1の問題点を解消するために制定されました。
    RIPv2では以下の機能が追加されました。

    • マルチキャストアドレスによるRIPパケットの送信

    • 認証機能のサポート(簡易パスワードまたはMD5)

    • サブネットマスクのサポート

    • ネクストホップアドレスのサポート

  • RIPng(RFC2080)
    RIPv2の仕様を踏襲し、IPv6ネットワーク向けに設計されたプロトコルです。
    IPv6ネットワークの経路情報を扱うという点以外はRIPv2の基本仕様から差異はありません。

本ページでは、RIP・RIPngの設定方法を説明します。

3. 経路数

RIP, RIPngで扱うことのできる経路数は以下のとおりです。

  • RIP (v1/v2)

    機種 経路数

    SWX3200-28GT
    SWX3200-52GT

    900

    SWX3220-16MT
    SWX3220-16TMs

    1024

    SWX3220-30MC
    SWX3220-30TCs

    1024

  • RIPng

    機種 経路数

    SWX3200-28GT
    SWX3200-52GT

    900

    SWX3220-16MT
    SWX3220-16TMs

    1024

    SWX3220-30MC
    SWX3220-30TCs

    1024

4. 基本設定

RIPの基本設定を行う上で参考とするネットワークは以下のとおりです。

image

SWX (1)での設定
SWX (1)は、192.168.0.0/24, 192.168.1.0/24, 192.168.3.0/24の3つのネットワークに接続しています。
network コマンドで各ネットワークを登録します。

!
vlan database
 vlan 2-3 state enable
!
interface port1.1
 switchport
 switchport mode access
!
interface port1.2
 switchport
 switchport mode access
 switchport access vlan 2
!
interface port1.3
 switchport
 switchport mode access
 switchport access vlan 3
!
interface vlan1
 ip address 192.168.0.1/24
!
interface vlan2
 ip address 192.168.1.2/24
!
interface vlan3
 ip address 192.168.3.3/24
!
router rip
 network 192.168.0.0/24
 network 192.168.1.0/24
 network 192.168.3.0/24
!

SWX (2)での設定
SWX (2)は、192.168.1.0/24, 192.168.2.0/24の2つのネットワークに接続しています。
network コマンドで各ネットワークを登録します。

!
vlan database
 vlan 2 state enable
!
interface port1.1
 switchport
 switchport mode access
!
interface port1.2
 switchport
 switchport mode access
 switchport access vlan 2
!
interface vlan1
 ip address 192.168.1.1/24
!
interface vlan2
 ip address 192.168.2.1/24
!
router rip
 network 192.168.1.0/24
 network 192.168.2.0/24
!

SWX (3)での設定
SWX (3)は、192.168.3.0/24のネットワークに接続しています。
network コマンドで各ネットワークを登録します。

!
interface port1.1
 switchport
 switchport mode access
!
interface vlan1
 ip address 192.168.3.1/24
!
router rip
 network 192.168.3.0/24
!

network コマンドでは、ネットワークアドレスの指定以外にもVLANインターフェースを指定することができます。
VLANインターフェースを指定した場合、そのVLANインターフェースに直結しているネットワークがRIPネットワークとなります。
SWX (3)の設定をVLANインターフェース指定で記述すると以下のようになります。

!
interface port1.1
 switchport
 switchport mode access
!
interface vlan1
 ip address 192.168.3.1/24
!
router rip
 network vlan1
!

5. 設定ガイド

RIP・RIPngでは、上記の基本設定に加えて経路情報のフィルタリングや認証といった設定を行うことができます。
本項は、状況に応じて適切な設定を行うための設定ガイドとなります。

5.1. RIPバージョンの設定

動作させるRIPのバージョンは、RIPプロセスとVLANインターフェースの両方で設定することができます。
RIPプロセスに対して設定したバージョンよりもVLANインターフェースに設定したバージョンが優先されます。

  • RIPプロセスでRIPバージョンを2とし、VLAN2インターフェースでRIPバージョンを1とします。
    この場合、VLAN1インターフェースではRIPv2が動作し、VLAN2インターフェースではRIPv1が動作します。

    Yamaha(config)# router rip
    Yamaha(config-router)# version 2
    Yamaha(config-router)# exit
    Yamaha(config)# int vlan2
    Yamaha(config-if)# ip rip send version 1
    Yamaha)config-if)# ip rip receive version 1

5.2. メトリック値の設定

RIPではホップ数がメトリックとして使用されますが、 offset-list コマンドを用いることで任意の経路のメトリック値を変更することができます。

  • 192.168.0.0/24宛の経路情報を受信したとき、メトリックを3増やした上でRIP経路表に取り込む。

  • 192.168.1.0/24宛の経路情報を送信するとき、メトリックを2増やした上で送信する。

    Yamaha(config)# access-list 10 permit any 192.168.0.0/24 any
    Yamaha(config)# access-list 11 permit any 192.168.1.0/24 any
    Yamaha(config)# router rip
    Yamaha(config-router)# offset-list 10 in 3
    Yamaha(config-router)# offset-list 11 out 2

5.3. 外部経路の再広告

静的経路やOSPF経路など外部経路をRIPネットワークに再広告する場合は、 redistribute コマンドを使用します。
再広告時のメトリック値も同時に指定することができます。

  • 静的経路をメトリック3としてRIPネットワークに再広告する。

    Yamaha(config)# router rip
    Yamaha(config-router)# redistribute static metric 3
  • OSPFプロセス2のOSPF経路をメトリック5としてRIPネットワークに再広告する。

    Yamaha(config)# router rip
    Yamaha(config-router)# redistribute ospf 2 metric 5

外部経路をRIPで再広告する場合のデフォルトメトリックは、 default-metric コマンドで設定します。
ただし、 redistribute コマンドでメトリックが指定されている場合にはそのメトリック値が優先されます。

  • 外部経路をRIPで再広告する場合のデフォルトメトリックを3とする。

    Yamaha(config)# router rip
    Yamaha(config-router)# default-metric 3

5.4. 経路情報のフィルタリング

RIBとRIP経路情報間で特定の経路情報のフィルタリングを行うことができます。

  • RIBに登録された経路情報の中で192.168.1.0/24宛の経路情報だけをRIPで広告しないようにする。

    Yamaha(config)# access-list 1 deny any 192.168.1.0/24 any
    Yamaha(config)# access-list 1 permit any any any
    Yamaha(config)# router rip
    Yamaha(config-router)# distribute-list 1 out
  • RIPで受信した経路の中で192.168.0.0/16の範囲の経路情報だけRIBに登録する。

    Yamaha(config)# access-list 1 permit any 192.168.0.0/16 any
    Yamaha(config)# access-list 1 deny any any any
    Yamaha(config)# router rip
    Yamaha(config-router)# distribute-list 1 in

5.5. 認証

RIPv2では、簡易パスワードまたはMD5ダイジェストを用いた認証に対応しています。
認証を用いることで悪意ある機器からの不正な経路情報広告などを防ぐことができます。
認証の設定はRIPを動作させるインターフェース毎に設定します。
認証を有効にしたインターフェースとRIPパケットを送受信する対向の機器でも認証を有効にする必要があります。

  • 簡易パスワードによる認証
    VLAN2インターフェースで「yamaha」をパスワードとする簡易パスワード認証を有効にする。

    Yamaha(config)# interface vlan2
    Yamaha(config-if)# ip rip authentication mode text
    Yamaha(config-if)# ip rip authentication string yamaha
  • MD5ダイジェストによる認証
    VLAN3インターフェースで「0a1b2c3d4e5f6789」をパスワードとするMD5ダイジェスト認証を有効にする。

    Yamaha(config)# interface vlan2
    Yamaha(config-if)# ip rip authentication mode md5
    Yamaha(config-if)# ip rip authentication string 0a1b2c3d4e5f6789

1つのインターフェースに対して複数のパスワードを設定する場合には、キーチェーンでのパスワード登録を行い、そのキーチェーンを各インターフェースで指定します。

  • VLAN2インターフェースで「yamaha」または「0a1b2c3d4e5f6789」をパスワードとする簡易パスワード認証を有効にする。

    Yamaha(config)#key chain KeyChainName
    Yamaha(config-keychain)#key 1
    Yamaha(config-keychain-key)#key-string yamaha
    Yamaha(config-keychain-key)#key 2
    Yamaha(config-keychain-key)#key-string 0a1b2c3d4e5f6789
    Yamaha(config-keychain-key)#exit
    Yamaha(config-keychain)#exit
    Yamaha(config)#int vlan2
    Yamaha(config-if)# ip rip authentication mode text
    Yamaha(config-if)#ip rip authentication key-chain KeyChainName

5.6. RIPの状態確認

RIPの設定状況や状態を表示するために以下のコマンドが用意されています。

  • RIPに関する設定状況やRIPの状態を表示する。

    Yamaha# show ip protocols rip
  • RIP経路表を表示する。

    Yamaha# show ip rip
  • インターフェース毎のRIPの状態を表示する。

    Yamaha# show ip rip interface
  • RIPの統計情報を表示する。

    Yamaha# show ip rip statistics

6. 注意事項

特になし

7. 関連文書

特になし